Looking into increased connection timeouts
Incident Report for packagecloud.io
Resolved
This incident has been resolved.
Posted over 2 years ago. Jul 06, 2016 - 12:32 PDT
Investigating
We are currently investigating this issue.
Posted over 2 years ago. Jul 06, 2016 - 12:21 PDT