Increased 403 Errors on package access

Incident Report for packagecloud.io

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 21:40 PDT

Update

This incident has been resolved - we've reverted the change that was causing the issue.
Posted Oct 23, 2025 - 21:38 PDT

Update

We have confirmed it does not affect PyPI and are continuing to investigate the issue.
Posted Oct 23, 2025 - 21:24 PDT

Investigating

We are currently investigating an increase in 403 (Forbidden) errors affecting some Packagecloud repositories. Users may experience access denied errors when attempting to read packages.
Our team is actively investigating the root cause and will provide updates as more information becomes available.
Posted Oct 23, 2025 - 21:12 PDT
This incident affected: API, Frontend, DNS, Deb/Apt Repositories, RPM/yum Repositories, Gem Repositories, and PyPI Repositories.