Duplicate entry for certain package uploads
Incident Report for packagecloud.io
Resolved
The workaround has resolve the issue of 'Duplicate Error' and repo install script issue that affected private repositories. We will work on expanding the namespace limits for private read tokens to ensure future scalability.
Posted Dec 19, 2022 - 09:04 PST
Update
We've released a fix to address the 'Duplicate Error, Aborting' issue encountered by users trying to upload packages. We're now monitoring customer reports and feedback.
Posted Dec 19, 2022 - 08:07 PST
Monitoring
We have released a fix to bypass the issue of repo install scripts not working as expected. We're monitoring customer feedback and report for that.
We have started working on a bypass for duplicate entry for package upload, with the ETA still expected to be 1400 UTC.
Posted Dec 19, 2022 - 05:21 PST
Identified
We have identified the issue to be related to the identifier limits in our database.
We're in the process of releasing a fix within the next hour 1400 UTC.
Posted Dec 19, 2022 - 04:19 PST
Investigating
Some customers have reported issue with uploading packages, suspected to be previously uploaded and deleted.
Some customers have also reported repo install scripts not working as expected as it cannot pull down the repo config for the system where packages are to be installed.
Posted Dec 19, 2022 - 02:14 PST
This incident affected: API, Frontend, Deb/Apt Repositories, RPM/yum Repositories, Gem Repositories, and PyPI Repositories.